No "Number of parameters" selector in Script Editor

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

No "Number of parameters" selector in Script Editor

m.laterza
This post has NOT been accepted by the mailing list yet.
I'm trying to write a script, but there is no "Number of parameters" selector in the Script Editor's "Parameters" tab:

Parameters tab in Script Editor

I'm using ILWIS 3.07.02, and these are my system features:
- Intel Core i5;
- Windows 7 Home Premium;
- 64 bit OS.
I can't understand why, and I'm asking for your help. Thank you.
Reply | Threaded
Open this post in threaded view
|

Re: No "Number of parameters" selector in Script Editor

José Santos
Hey laterza,

On my versions (3.3.1 and 3.8.3) I have access to the parameters and also the option to chosen them. Try to update ILWIS for is last version 3.8.3. Can be a bug in that version you are using.

Good Luck

Regards,
José Santos
José Santos GIS Analysis Expert
Reply | Threaded
Open this post in threaded view
|

Re: No "Number of parameters" selector in Script Editor

Bas Retsios
Hi!

Indeed it is a known issue that the parameters tab in the script editor
does not display correctly on recent computers. The reason is that the
variable that contains the screen pixel dimensions of the parameters tab
was not initialized, thus contained random values. Why on older
computers the parameters tab does display correctly is still a mystery
to us. This issue is in ILWIS 3.8.3 and also in all older versions (back
to ILWIS 3.31 from 2005 or even older). The only workaround was to
temporarily use another computer where the parameters tab displays
correctly, and edit the script there.

However I have just solved the problem, and the solution will become
available in ILWIS 3.8.4 which is soon to be made available.

Cheers,

Bas Retsios
ILWIS team

On 18/2/2014 11:44, José Santos wrote:

> Hey laterza,
>
> On my versions (3.3.1 and 3.8.3) I have access to the parameters and also
> the option to chosen them. Try to update ILWIS for is last version 3.8.3.
> Can be a bug in that version you are using.
>
> Good Luck
>
> Regards,
> José Santos
>
>
>
> -----
> José Santos
> GIS Analysis Expert
> --
> View this message in context: http://ilwis.forum.52north.org/No-Number-of-parameters-selector-in-Script-Editor-tp4025633p4025640.html
> Sent from the 52° North - ILWIS Community Forum mailing list archive at Nabble.com.
> _______________________________________________
> Ilwis mailing list
> [hidden email]
> http://list.52north.org/mailman/listinfo/ilwis
> http://ilwis.forum.52north.org

_______________________________________________
Ilwis mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/ilwis
http://ilwis.forum.52north.org